Instalando .NET Framework 4.0 e Visual Studio 2010 Beta 1

Se você já tentou instalar e recebeu a mensagem:
”The .NET Framework version 4 cannot be installed because the .NET Framework version 1.0 is already installed on your computer”

Creio que a sua primeira ação foi ir no painel de controle e tentar remover o .NET Framework 1.0.
Mas você não encontrou o .NET Framework 1.0 e descobre que ele não estava instalado.

Para resolver esse problema use a ferramenta abaixo para remover as versões 1.0 e 1.1 do seu computador.

Agora não me perguntem por que o Framework 1.0 e o 1.1 estavam instalados na máquina e não estavam na lista de programas instalados.
Feito isso, você poderá instalar o Framework 4.0 e logo em seguida o VS2010.

image

Boa sorte!

Rodrigo Kono
Microsoft MVP [ASP.NET] MCTS – MCP